gpdf.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19940 580b73a315a2
permissions -rw-r--r--
access control test #4

#
# spec file for package gpdf
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:		gpdf
License:	GPL
Group:		System/GUI/GNOME
Version: 	2.10.0
Release:	1	
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	A GNOME PDF Viewer based on Xpdf
Source:		http://ftp.gnome.org/pub/GNOME/sources/gpdf/2.10/gpdf-%{version}.tar.bz2
Source1:        gpdf.1.gz
Patch1:         gpdf-01-gconf-install.diff
Patch2:         gpdf-02-fit-full-screen.diff
Patch3:         gpdf-03-pkgconfig.diff
Patch4:		gpdf-04-lookupglyph.diff
URL:		http://www.purl.org/NET/gpdf
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/doc
Prereq:         GConf

%define	libgnomeui_version 2.6.0
%define gnome_vfs_version 2.6.0
%define libgnomeprintui_version 2.6.0
%define libglade_version 2.3.6
%define xpdf_version 1.01


Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	gnome-vfs >= %{gnome_vfs_version}
Requires:	libgnomeprintui >= %{libgnomeprintui_version}
Requires:	libglade >= %{libglade_version}
Requires:       xpdf >= %{xpdf_version}
BuildRequires:	libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:	gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires:	libgnomeprintui-devel >= %{libgnomeprintui_version}
BuildRequires:	libglade-devel >= %{libglade_version}

%description
Gpdf is an open source viewer for Portable Document Format (PDF)
files.  (These are also sometimes also called 'Acrobat' files, from
the name of Adobe's PDF software.)  The Gpdf project also includes a
PDF text extractor, PDF-to-PostScript converter, and various other
utilities.

Gpdf is designed to be small and efficient.  It can use Type 1,
TrueType, or standard X fonts.
#'  <-- keep emacs syntax highlighting happy

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
	    --libexecdir=%{_libexecdir}		\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm -f $RPM_BUILD_ROOT%{_datadir}/mime-info/gpdf.keys

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gpdf.schemas"
for S in $SCHEMAS; do
 gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr(-,root,root)
%doc AUTHORS CHANGES COPYING INSTALL NEWS README
%{_bindir}/gpdf
%{_libdir}/bonobo/servers/*
%{_datadir}/gpdf/glade/*.glade
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/application-registry/*.applications
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_libexecdir}/gnome-pdf-viewer
%{_mandir}/man1/*
%{_datadir}/pixmaps/*
%{_datadir}/applications/*
%{_datadir}/omf/gpdf/*.omf
%{_datadir}/gnome/help/gpdf/*
%{_sysconfdir}/gconf/schemas/gpdf.schemas

%changelog
* Fri Sep 09 2005 - [email protected]
- adding back in gpdf-05-lookupglyph.diff for fixes for 6268411,
  6219093

* Fri Jul 01 2005 - [email protected]
- pkgconfig patch

* Fri May 20 2005 - [email protected]
- Updated gpdf-02-lookupglyph.diff to render truetype embedded 
  fonts correctly. Fixes bug #6268411.

* Thu May 19 2005 - [email protected]
- port to 2.10.0

* Wed Apr 20 2005 - [email protected]
- Updated gpdf-02-lookupglyph.diff to take care that ligatures
  of type1 fonts are displayed properly.
  Fixes bug #6219093.

* Tue Feb 15 2005 - [email protected]
- Correct path used in last commit (for 6219559).

* Mon Feb 14 2005 - [email protected]
- #6219559: Delete omf files on Linux, as gpdf help should not appear because
  it is not supported.

* Tue Feb 01 2005 - [email protected]
- Update gpdf-03-multi-launch-apps.diff to open the DnD PDF file on
  the PDF viewer launcher on panel. Fixes bug #4925871.

* Wed Jan 26 2005 - [email protected]
- #6219559: Delete some doc files on Linux, those that are only used on Solaris.

* Fri Jan 21 2005 - [email protected]
- #6219559 : Only deliver gpdf help on Solaris, do not deliver on Linux

* Thu Jan 20 2005 - [email protected]
- Added patch gpdf-07-fit-full-screen.diff to patch bug #6194586

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Tue Jan 11 2005 [email protected]
- URL updated

* Tue Oct 05 2004 [email protected]
- Added gpdf-06-g11n-i18n-ui.diff to localize bookmark.
  Fixed 6173631.

* Wed Sep 15 2004 [email protected]
  Integrating gpdf-06-remove-acroread.diff into gpdf-03-multi-launch-apps.diff
  So removing gpdf-06-remove-acroread.diff

* Wed Sep 15 2004 [email protected]
- No need of hardcoding the path for acroread.

* Wed Sep 08 2004 [email protected]
- Fixes overwriting of files for `Save As` option.
  Fixes bug #5083054.

* Tue Aug 31 2004 [email protected]
- Changed patch3 - gpdf-03-multi-launch-apps.diff for pdflaunch.c
  Fixes bug# 5087934

* Wed Aug 25 2004 [email protected]
- Added l10n help contents with patch

* Tue Aug 24 2004 [email protected]
- remove mime info file
* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Thu Aug 05 2004 - [email protected]
- Update patches/gpdf-03-multi-launch-apps.diff to add 'pdflaunch'
  to .applications file. Fixes bug #5081909.
 
* Mon Jul 26 2004 - [email protected]
- Bump version to 0.132. Fixes #5072626

* Mon Jul 26 2004 - [email protected]
- Install a crackrock script so that we have an acccessible
  pdf viewer [gpdf] or non-accessible pdf viewer [acroread] which
  is run depending on a few gconf keys and architecture. Sigh.

* Thu Jul 22 2004 - [email protected]
- Remove the menu entry so that it doesn't show up.

* Thu Jul 22 2004 - [email protected]
- Remove the mime key so that acroread is default pdf
  viewer.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gpdf-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- Ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue Jun 22 2004 [email protected]
- Added dependency on xpdf so language packs are available to gpdf

* Tue Jun 15 2004 [email protected]
- Added glyph lookup for embedded font patch gpdf-02-lookupglyph.diff

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to gpdf-l10n-po-1.1.tar.bz2

* Thu Apr 22 2004 - [email protected]
- bump to 0.131

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gpdf-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - [email protected]
- Use JDS CBE, and remove annot compile patch.

* Mon Mar 22 2004 - [email protected]
- fix compile prob by adding patch : 02-annot-compile-prob

* Mon Mar 22 2004 - [email protected]
- Bump to 0.125 and remove all the patches -
  install-data-local, thumnail-cc, weight-undefined
  and potfiles.

* Thu Mar 11 2004 - [email protected]
- added gpdf-04-g11n-potfiles.diff

* Tue Mar 02 2004 - <[email protected]>
- Patch 03 to fix compile error

* Mon Feb 16 2004 - <[email protected]>
- Bump to 0.122, remove patch 01-deprecated, 
  add patch 01-install-data-local

* Thu Jan 09 2004 - <[email protected]>
- Add patch #1 to fix build breakage

* Wed Dec 17 2003 - <[email protected]>
- Bump to 0.120 tarball

* Fri Nov 21 2003 - <[email protected]>
- Fixes 4949480. By not installing gpdf.keys

* Wed Oct 15 2003 - <[email protected]>
- update to version 0.111, reset release.

* Tue Oct 07 2003 - <[email protected]>
- Remove menu entry patch and dont install .desktop file

* Tue Aug 05 2003 - <[email protected]>
- Update tarball, bump version, reset release.

* Thu Jul 17 2003 - <[email protected]>
- Add a menu icon

* Mon Jul 14 2003 - <[email protected]>
- Initial spec file.