gucharmap.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19838 42a3a4365a3b
permissions -rw-r--r--
access control test #4

#
# spec file for package gucharmap
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#


Name:         gucharmap
License:      GPL
Group:        System/GUI/GNOME
Version:      1.4.3
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Unicode Character Map
Source:       http://ftp.gnome.org/pub/GNOME/sources/gucharmap/1.4/gucharmap-%{version}.tar.bz2
Source1:      gnome-character-map.1.gz
Source2:      gucharmap.1.gz
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define glib2_version 2.4.0
%define pango_version 1.4.0
%define gtk2_version 2.4.0
%define popt_version 1.7
%define libgnomeui_version 2.6.0
%define scrollkeeper_version 0.3.14

BuildRequires:  glib2-devel >= %{glib2_version}
BuildRequires:  pango-devel >= %{pango_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  popt-devel >= %{popt_version}
BuildRequires:  scrollkeeper >= %{scrollkeeper_version}
Requires:       libgnomeui >= %{libgnomeui_version}

%description
This package contains a unicode character map for the GNOME Desktop.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--localstatedir=/var/lib
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/pixmaps/*
%{_datadir}/applications
%{_libdir}/*.so.*
%{_libdir}/*.so
%{_mandir}/man1/*
%{_includedir}/gucharmap/*
%{_libdir}/pkgconfig/*.pc
%{_datadir}/omf/*
%{_datadir}/gnome/help/*

%changelog
* Wed May 18 2005 - [email protected]
- Bump to 1.4.3

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Fri Nov 12 2004 - [email protected]
- Updated l10n help tarball and patch

* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents with patch

* Thu Aug 05 2004 - [email protected]
- Integrated 0.3 docs tarball from [email protected]

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gucharmap-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- port to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 11 2004 - [email protected]
- Integrated 0.2 docs tarball from [email protected]

* Wed May 12 2004 - [email protected]
- Updated l10n content to gucharmap-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 15 2004 - [email protected]
- Bump to 1.4.1

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gucharmap-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - [email protected]
- Bump to 1.3.2

* Tue Mar 16 2004 - [email protected]
- Remove online help and .desktop patches since
  they're upstream.

* Mon Feb 23 2004 - [email protected]
- Bump to 1.3.0
- Re-apply patch 01-menu-name-description.diff
- Remove 02-potfiles.diff
- Port patches :
	04-add_help.diff
	05-help_make.diff
	06-l10n-online-help.diff

   From QS and into one patch
	02-add-l10n-help.diff
* Wed Dec 17 2003 - [email protected]
- Bump to 1.2.0

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Supported keyword since we're
  removing Extras menu.

* Fri Oct 13 2003 - [email protected]
- Update to 1.0.0

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Aug 08 2003 - [email protected]
- Add and remove some mnemonics

* Fri Jul 25 2003 - [email protected]
- Add libgnomeui to Requires

* Thu Jul 10 2003 - [email protected]
- Add a patch to add a menu description and 
  remove the 'Unicode' part of the menu name.

* Tue Jul 01 2003 - [email protected]
- Initial Sun release