libexif-gtk.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19886 91656ff1d81e
permissions -rw-r--r--
access control test #4

#
# spec file for package libexif-gtk
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         libexif-gtk
License:      GPL
Group:        Development/Libraries/C and C++
Version:      0.3.5
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GTK widgets for viewing EXIF information
Source:		  http://umn.dl.sourceforge.net/libexif/%{name}-%{version}.tar.bz2
Patch1:       libexif-gtk-01-enable-deprecated.diff
Patch2:       libexif-gtk-02-gettext.diff
Patch3:       libexif-gtk-03-solaris.diff
Patch4:       libexif-gtk-04-uninstalled-pc.diff
URL:          http://sourceforge.net/projects/libexif
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
DocDir:       %{_defaultdocdir}/libexif-gtk
Autoreqprov:  on
Prereq:       /sbin/ldconfig


%define libexif_version 0.5.9
Requires:      libexif >= %{libexif_version}
BuildRequires: libexif >= %{libexif_version}

%description
This library contains GTK widgets for viewing the EXIF informations within
JPEG images created by some types of digital cameras.

%prep 
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
CFLAGS="$CFLAGS $RPM_OPT_FLAGS" 	\
	./configure 			\
		--prefix=%{_prefix} 	\
		--libdir=%{_libdir}	\
		--disable-static
make -j $CPUS

%install
make DESTDIR=${RPM_BUILD_ROOT}/ install-strip
#clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf ${RPM_BUILD_ROOT}

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_libdir}/lib*so*
%{_libdir}/pkgconfig/*
%{_includedir}/*
%{_datadir}/locale/*

%changelog -n libexif-gtk
* Wed Jun 15 2005 - [email protected]
- Add more libs to LDADD so that it builds with the new pkgconfig

* Wed Jun 15 2005 - [email protected]
- Bump to 0.3.5

* Wed Jul 13 2004 - [email protected]
- fix for rpm4 packaging

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libexif-gtk-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jun 17 2004 - [email protected]
- Run glib-gettextize and replace po/Makefile.in.in with standard
  ones found in %{_datadir}/glib-2.0/gettext/.

* Wed Jun 06 2004 - [email protected]
- Added needed patches for Solaris.

* Wed May 12 2004 - [email protected]
- Updated l10n content to libexif-gtk-l10n-po-1.1.tar.bz2

* Mon Apr 12 2004 - [email protected]
- Add $ACLOCAL_FLAGS to aclocal call, making Solaris more happy.

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libexif-gtk-l10n-po-1.0.tar.bz2

* Thu Mar 18 2004 - <[email protected]>
- Added URL Tag

* Thu Mar 11 2004 - [email protected]
- added libexif-gtk-03-g11n-potfiles.diff

* Wed Feb 04 2004 - <[email protected]>
- l10n tarball, and patch

* Fri Jan 16 2004 - <[email protected]>
- Enable Deprecated patch

* Tue Oct 14 2003 - <[email protected]>
- Upgrade tarball to 0.3.3 for QS

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Wed Jul 16 2003 - [email protected]
- Initial version