libwnck.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19719 d184ca39d269
permissions -rw-r--r--
access control test #4

#
# spec file for package libwnck
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         libwnck
License:      GPL
Group:        System/Libraries/GNOME
Version:      2.10.0
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Window Navigator Construction Kit Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/libwnck/2.10/libwnck-%{version}.tar.bz2
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define gtk2_version 2.2.4
%define startup_notification_version 0.5

Requires: gtk2 >= %{gtk2_version}
Requires: startup-notification >= %{startup_notification_version}
BuildRequires:	gtk2-devel >= %{gtk2_version}
BuildRequires:  startup-notification-devel >= %{startup_notification_version}

%description
The Window Navigator Construction Kit is a library which can be used
to control windows on your desktop, including API for writing 
Task Lists, Workspace Switchers and Window Lists.

%package devel
Summary:      Window Navigator Construction Kit Development Library
Group:        Development/Libraries/GNOME
Autoreqprov:  on
Requires: %name = %{version}
Requires: gtk2-devel >= %{gtk2_version}

%description devel
The Window Navigator Construction Kit is a library which can be used
to control windows on your desktop, including API for writing 
Task Lists, Workspace Switchers and Window Lists.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%{_libdir}/libwnck*.so.*
%{_datadir}/locale/*/*/*

%files devel
%{_libdir}/libwnck*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/gtk-doc

%changelog
* Fri Jun 24 2005 - [email protected]
- Add patch pkgconfig.diff that adds the required libs explictly

* Fri May 10 2005 - [email protected]
- Bump to 2.10

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to libwnck-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to libwnck-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to libwnck-l10n-po-1.0.tar.bz2

* Tue Mar 23 2004 - [email protected]
- Bump to 2.6.0 and remove the uninstalled, 
  potfiles and null atom patches - upstream.

* Sun Mar 21 2004 - [email protected]
- add patch 03 instead of adding patch 02 twice.

* Fri Mar 19 2004 - <[email protected]>
- add patch 2 fixing null atom names from causing coredummp on Solaris.

* Thu Mar 11 2004 - [email protected]
- libwnck-02-g11n-potfiles.diff

* Fri Feb 20 2004 - [email protected]
- Update Distro, l10n tarball

* Tue Feb 17 2004 - [email protected]
- Add uninstalled.pc file needed for the Solaris builds

* Fri Oct 10 2003 - <[email protected]>
- update to 2.4.0.1

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Thu Jul 10 2003 - [email protected]
- Added .po tarball

* Fri May 30 2003 - [email protected]
- Backport fitt's law patch for gnome-panel 2.3.x.

* Tue May 13 2003 - [email protected]
- initial Sun release.