system-tools-backends.spec
author dermotm
Mon, 24 Jul 2006 12:30:39 +0000
branchgnome-2-10
changeset 19949 94f49bf19351
parent 19719 d184ca39d269
permissions -rw-r--r--
access control test #4

#
# spec file for package system-tools-backends
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#


Name:		system-tools-backends
License:	GPL
Group:		System/GUI/GNOME
Version:	1.2.0
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	Backends for the GNOME System Tools
Source:		http://ftp.gnome.org/pub/GNOME/sources/system-tools-backends/1.2/%{name}-%{version}.tar.bz2
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on

%define glib2_version 2.3.0

Requires:	glib2 >= %{glib2_version}
BuildRequires:  glib2-devel >= %{glib2_version}
BuildRequires:  intltool

%description
The System Tools Backends are a set of cross-platform scripts for Linux and 
other Unix systems. The backends provide an standard XML interface for 
modifying the configuration regarless of the distribution that's being used.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_libdir}/pkgconfig/
%{_datadir}/setup-tool-backends/
%{_datadir}/aclocal/
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%changelog
* Tue May 24 2005 - [email protected]
- Initial spec